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Contributions 

This is a self-study report that is not related to my co-op job.   The Department of Electrical and 

Computer Engineering has approximately ninety faculty members, fifteen research chairs, forty-five staff, 

350 graduate students, and 1500 undergraduate students in the two core programs of electrical and 

computer engineering alone. Within the Undergraduate Studies Office, there are ten faculty and three staff 

focused on all academic aspects of the program:  the courses and the technical presentation and work-term 

report milestones. 

The objective of the department is to engage in research and to educate both undergraduate and graduate 

students in the fields related to electrical and computer engineering including 

1. communications, modulation and coding, multimedia, wireless; 

2. networks, mobility, distributed computing; 

3. energy distribution, motors/generators, power electronics, energy marketing; 

4. control, automation, robotics, mechatronics; 

5. digital architectures, embedded computers, formal specification and design; 

6. analog or digital devices, circuits, VLSI, micro-/nano-fabrication methods; 

7. microwave (radio frequency) or photonic devices and systems; 

8. signal processing, computational intelligence, soft computing; 

9. software systems, components, security, embedded software; and 

10. software engineering, requirements specification, software architectures, verification.  

The department has faculty members engaged in research throughout all of these areas. 

As a faculty member within the department I have taught a number of courses, though I have focused on 

ECE 250 Algorithms and Data Structures and ECE 104/204 Numerical Methods. For the former I have 

set up a web site which includes an on-line tutorial for C++, lecture material which includes a complete 

set of slides for all classes, a unique approach to understanding the purpose of data structures based on the 

relations of the data, instructional implementations of the algorithms for many of the data structures 

covered in the course, six laboratories, a project testing environment, homework, and tutorials. For the 

latter, I have created an on-line text which has been used at other universities. I have also been an officer 

of the department in the roles of Electrical Engineering Undergraduate Academic Advisor and the 

Graduate Admissions Officer. I have been the technical presentation milestone coordinator and evaluator 

as well as the Sir Sandford Fleming technical speaking competition faculty coordinator. As part of this 

process, I have developed an on-line text entitled Guidelines for Giving Technical Presentations. I have 

designed the course material for MATH 215 Linear Algebra for Electrical and Computer Engineers and 

have spent a significant amount of time working on the design of the MATH 211 and MATH 212 

Advanced Calculus 1 and 2 including the design of the laboratories. I am the webmaster and designer of 
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the web pages of the department. I have written the Professional Practice Examination through 

Professional Engineers Ontario (PEO) and in the process of studying I developed a set of web pages 

which cover the associated material. Finally, one of my first tasks was to mark work-term reports. My 

skills at English grammar, as my masters supervisor may attest, were at this point relatively weak and in 

the process of marking the work-term reports, I quickly found that I needed significant remedial 

instruction in the English language. Fortunately, being on a university campus, I found a student doing 

work in grammatical theory to help explain many of the concepts. I am most thankful to the “Grammar 

Bytes!” web site by R.L. Simmons and the Canadian Writer’s Handbook by W.E. Messenger and 

published by Oxford University Press. 

As a work-term report marker, I had the opportunity to read hundreds of undergraduate work-term 

reports. Many were excellent but others seemed to lack the simplest features with obvious errors such as 

changing alignments, uncentred figures, tables created from grids of lines, dangling cross-references, etc. 

After reading one such report, it became obvious that students did not have the resources to properly 

create such a report and many used techniques more tedious and frustrating than tools that should have 

been, from my experience with LaTeX, available in Word. Once I had almost finished this report, I was 

made aware of Jason Pang’s document “Writing a Report using Microsoft Word’s Tools”; however, 

Jason’s document, while complete for Word 2004, does not have some of the best practices which are 

available in Word 2010. Hopefully this report will help students write more professional appearing 

engineering documents with less effort by taking advantage of the tools available and therefore, perhaps, 

spend more time on the engineering analysis and judgment which are most critical to the work of a 

professional engineer. 
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Summary 

The main purpose of the report is to inform undergraduate students how they can use the word-processing 

tools provided with Microsoft Word 2010 to produce professional engineering reports with a minimum of 

effort. 

The major points documented/covered in this report are three categories:  the Word environment, the tools 

of the engineer, and the end matter. The first is divided into the structural sectioning of the document, the 

logical sectioning of the body, and other features including page layout, style, and review. The second 

discusses the display of numbers and units, figures, tables, and equations. The last describes citations, 

references, and appendices. 

The major conclusions in this report are that Microsoft Word, while not as powerful as LaTeX, has many 

tools that will help the author in preparing a professional report without having to worry about the details 

and that students, unfortunately, rather than avail themselves to these tools, will use Word as a text editor. 

Word can help the author track and reference sections, figures, tables, and equations. 

The major recommendations in this report are that first-year students are capable of understanding the 

relevant features of Word and should, with the first work-term report, learn the tools necessary to produce 

professional engineering reports with a minimum of unnecessary effort. Understanding the features and 

functions available will also aid students in preparing lab reports and documentation they will need to 

produce throughout their undergraduate career. 
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1 Introduction 

When a professional engineer provides a service to the public, often the sole product of the 

contract is a single report that has been sealed by the engineer responsible. Free enterprise ensures 

that the effort required performing the investigations and to apply the necessary engineering 

judgment and analysis required to determine and support the recommendations of the report will 

be commensurate with the contracted fee. Never-the-less, the only product that the client will 

receive is the report. While the engineer’s seal is meant to demonstrate that the client can rely on 

the report in the pursuit of the client’s objectives and goals, an unprofessional report will erode 

that trust. 

When an engineering report appears unprofessional—and it is the small things that will count—

the client will question the report. They will see the errors, the typos, the poor formatting, etc., 

and each transgression will distract the client and the perceived trust in the report will diminish. 

Consequently, a professional engineer must produce a report of which the appearance is as 

professional as the work that went into determining and supporting the conclusions and 

recommendations therein. Today, many professional engineers and engineering students will use 

Microsoft
®
 WordTM, but personal observation has shown that rather than using it as a word 

processor, many will use it naïvely as a text editor. The consequences are both hidden and costly:  

hidden because every student believes that he or she will write the perfect document in the first 

iteration and therefore all the formatting features will not be necessary; costly because the student 

will spend many hours performing useless formatting tasks which are, with often negligible 

effort, automatable. There are many external reasons for this naïve approach to writing reports:  

students may not recognize that their problems have plagued others since before they were born 

and they may not know the correct terminology to describe either the problem or the solution they 

seek; Microsoft’s help pages are designed for the average user and often will frustrate a student 

with their simplicity; and books, such as Office Word 2007 Step by Step, are over 500 pages long, 

most of which is often trivial or irrelevant to the goal at hand. 

This report attempts to highlight those features of Word necessary to produce a professional 

report using the appropriate and very powerful word-processing tools available in this product 

[1]. As an engineering student, one hour spent reading and thinking about this report will return 

many hours in the future, will significantly reduce stress, and may even make certain aspects of 

the student’s undergraduate career less tedious. It will allow a student to allocate more time to 

ensure that the items in the departmental checklist are satisfied. The student, however, must still 



 

2 

ensure the report has an appropriate structure and flow, a sufficiently and appropriately detailed 

presentation, correct and consistent spelling and grammar, and the necessary engineering analysis 

and judgment resulting in the appropriate technical content. 

This report will first review the high-level structure of an engineering report and demonstrate how 

a Word document can be divided into structural sections with the specified page numbering. This 

is followed by the application of headings to break the body of the report into numbered logical 

sections, subsections, and sub-subsections. Instructions are given for creating a table of contents 

and for cross-referencing sections elsewhere in the report. Other significant features of Word are 

then highlighted including page layout, styles, and reviews. Switching the focus to aspects related 

to professional engineering, this report continues with a section on the presentation of numbers 

and units followed by three sections on figures, tables, and equations, respectively. Comments 

and discussions are included about the best practices for using these components, automatically 

cross referencing them elsewhere in the document, and about creating lists of figures and tables. 

The body ends with discussion of glossaries and creating and citing a list of references, together 

with a discussion on plagiarism. Finally, the purpose and use of appendices in professional 

engineering reports is discussed. The conclusions will highlight the best features discussed in the 

body of the report followed by recommendations. To ensure that all fields are correctly updated 

and sequenced, the reader should refer to Appendix A Word 2010 checklist before printing the 

report. This appendix provides a list of actions that must be taken to ensure certain items in the 

requirements are satisfied. 

It is assumed that the reader has some familiarity with the interface Word 2010; however, we will 

define a standard means of referencing the available features. Figure  shows the Microsoft ribbon 

with the Home tab selected. Other tabs include Insert, Page Layout, References, Mailings, 

Review, View, as well as other tabs featuring add-ons. For the Home tab, the ribbon is broken 

into five groupings—Clipboard, Font, Paragraph, Styles, and Editing—and each of these 

groups contain a number of related features.  

 

Figure 1. The Word 2007 ribbon interface. 

A reference to a particular feature will be written as Ribbon Tab→Group→Feature describing 

heirarchy which must be followed to access the feature.  If a feature is a drop-down menu, we 

will simply append the menu item to this sequence. 
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The reader should note that while this report follows the general structure of the work-term 

report, it is primarily a manual on the usage of Word in the context of preparing engineering 

reports;  consequently, it is presented in a teaching style which is not necessarily appropriate for a 

report meant to demonstrate engineering analysis and judgment. The reader is therefore warned to 

avoid considering this document as a standard for work-term report submissions. Among other 

things, the length of the body significantly exceeds the 15-page absolute maximum length of a 

work-term report. 
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2 The structural sections of the report 

An engineering report is usually divided into three physical sections:  front matter, the body and 

back matter. The pages in the front matter are numbered using lower-case Roman numerals while 

the pages of the body and the back matter are numbered using Arabic numerals restarting with 

page one for the first page of the body. Word allows the user to create structural sections and 

allows different formatting in the header and footer in each section. In addition, the title page of a 

structural section may have a separate page-numbering format from the balance of the section, 

but the work-term report guidelines require that neither the title page nor the letter of submittal 

have page numbers [2]. To achieve this in Word, it is necessary to break the document into three 

structural sections:  one for the first two pages (title page and letter of submittal), one for the 

balance of the front matter, and the last for the body and back matter. Unfortunately, the word 

section has two definitions in this report and I will refer to the partitions of a Word document as 

structural sections. The other definition deals with the subdivisions within a document including 

chapters (for books), sections, subsections, etc. These sections will be referred to as logical 

sections.  

2.1 Creating structural sections 

To divide a document into multiple structural sections, place the cursor where the break is to be 

inserted and select Page Layout→Page Setup→Breaks and from the drop-down menu under 

Section Break, select Next Page from the as is shown in Figure 2Error! Reference source not 

found.. The document must be divided into three structural sections:  the first will contain the 

title page and the letter of submittal, the second the balance of the front matter, and the third the 

body and the back matter. 
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Figure 2. Creating a section break in a Word document. 

To see the section breaks, select Home→Paragraph→¶ (a pilcrow). This toggles the appearance 

of paragraph marks, page breaks, structural section breaks, and other hidden formatting symbols. 

By turning this on, the author will see structural section breaks, forced page breaks, and even 

spaces. While this may appear to be initially distracting, it is possible to not only become familiar 

with it, but to even prefer it to the default WYSIWYG environment. 

2.2 Setting page numbers 

The next step is to add page numbers to each of the structural sections. Move the cursor into the 

second structural section and select Insert→Header&Footer→Page Number→ 

Bottom of Page→Plain Number. Next, we need to modify the style of the page numbers in this 

section:  Select Format Page Numbers… from the same drop-down box to launch the Page 

Number Format dialog. In this dialog, select the Number format i, ii, iii, … and modify the radio 

button Start at: iii. Next, move the cursor to the third section, repeat the process but chose Arabic 

numbers and set the radio button to Start at: 1.  

2.3 Summary of structural sections 

This first logical section has discussed the fundamental partitioning of a Word document into 

structural sections. Each structural section may contain its own style of formatting and style in the 

header and footer, specifically the page numbering. 

3 Logical sections within the report body 

Books are divided into chapters while chapters and reports are often divided into logical sections 

that may be further subdivided into subsections and then sub-subsections, etc. This partitioning is 
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necessary to provide flow and context for the reader:  the sequence of sections reflects the logical 

flow and reasoning of the author while the section titles provide a high-level description and 

context for the material contained within the sections. We will look at the appropriate sectioning 

of an engineering analysis report, how to create the appropriate sections, how to generate a table 

of contents based on the sections, and how to refer to a specific section from another part of the 

document. 

3.1 Engineering report structure 

An engineering report provides a framework within which the author can present his or her 

engineering analysis or design to the reader.  The analysis and design cannot be presented in 

isolation, and it is therefore necessary to package such reports within a standard format that 

provides context and supporting materials to the reader.  Thus, a standard report will contain at 

least some of the following components, including 

1. a title page, 

2. a letter of submittal, 

3. the contributions of the author, 

4. a summary, 

5. a table of contents, 

6. a lists of figures, 

7. a list of tables, 

8. the body, 

9. a glossary, 

10. references, and 

11. appendices. 

In-house reports—those not meant to be read by individuals outside of a company—are often 

more brief, but when an engineer prepares a report for a client, it is more likely than not that a 

majority of these components will be present.  While most engineers will spend their entire 

careers as employees, and therefore they may not see the use of many of these additional 

components, the consulting engineer will recognize the significance of the clear communication 

such reports provide.  Apart from the first two, each of these will appear in their own section, 

with the body and appendices possibly broken into further sections and subsections. 

The body of the report is itself divided into sections such as 

1. an introduction and background; 

2. a statement of the engineering problem; 

3. a list of requirements, criteria, and metrics together with a full discussion; 

4. a list of possible solutions together with descriptions and discussion; 
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5. the engineering analysis and design with a discussion and demonstration of engineering 

judgment; and 

6. conclusions and recommendations for the reader [2], [3]. 

Apart from the title page, letter of submittal, table of contents, and lists of figures and tables, each 

of these components and the sections and subsections of the body and appendices must appear in 

the table of contents.  Maintaining such a table has been issue which has plagued authors for 

centuries and Word has the tools that can assist in maintaining this synchronization.  The next 

three sections will describe how to maintain such  

3.2 Styles in Word 

A document should have a consistent look-and-feel, in the sense that all titles should be in the 

same typeface and size, images should be consistently captioned, lists should be equally indented, 

and so on.  In order to facilitate this, Word provides for Styles, where a body of text can be 

designated to be of a certain style, any change to the style will be automatically applied to all text 

designated as that style.  Word considers any text separated by hard returns (Enter) to be a 

paragraph—even if it is only one word on a single line, while a soft return (Shift-Enter) does not 

indicate a new paragraph.  A style can apply either to 

1. entire paragraphs, 

2. individual characters in a paragraph (for example, as emphasis), or 

3. to both (linked). 

Most of the styles we will use apply to paragraphs, but this document does use one character 

style:  Word Feature.  In addition to a bold emphasis, the text is colored Microsoft Word blue 

with the benefits including 

1. being able to change all instances of anything emphasized as such simultaneously, and 

2. allowing text readers to indicate that the text is styled as being a Word Feature as 

opposed to stating that the text has been formatted as bold and colored blue. 

The default styles that we will base our engineering report styles on include 

1. Normal for regular paragraph text with full justification; 

2. No Spacing, like Normal, but with left alignment and single-line spacing between 

paragraphs; 

3. Caption for figures and table captions; and 

4. Heading 1 through and Heading 9 for chapter and section titles. 
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Some of the available styles are always visible under the Home→Style grouping, as shown in 

Figure 3. 

 

Figure 3.  The visible styles. 

Selecting the  button causes more to appear, as shown in . 

 
Figure 4.  A drop-down selection of styles. 

Finally, however, selecting the  button in the lower right of the grouping will bring up a Styles 

dialog, as shown in Figure 5. 
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Figure 5.  The Styles dialog. 

3.3 Modifying styles 

Having introduced styles, we will now look at how we can make modifications to the various 

styles.  To modify a style, right click on either the icon in ribbon or the item in the Styles dialog.  

From this menu, select Modify….  This will bring up the Modify Style dialog.  For example, if 

you have never modified the styles of Microsoft Word, you should get a dialog that looks like 



 

10 

 

Figure 6.  The Modify Style dialog. 

Most obviously, one can change the formatting, including the typeface, font size, emphasis (bold, 

italics and underlining) and color.  Below this, you can change the justification (left, centered, 

right and full), spacing (singe, 1.5 and double), space after a hard return (the end of a paragraph) 

and indentation.  More subtle issues, however, appear above this.  However, more relevant are the 

formatting features, accessed by selecting the  button in the lower-left corner.  These 

features more selective control of 

1. the typeface and font by selecting Font…, allowing you additional decorations and 

emphasis such as strikethrough and small caps, and 

2. the appearance of paragraphs by selecting Paragraph… . 

The Paragraph dialog has two tabs, and both are relevant to reports: 
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1. The first tab, Indents and Spacing, allows you to control the line spacing and how much 

space appears before and after any paragraph that has been designated as this style.  In 

order to achieve a spacing of 1.15, it is necessary to select Line spacing: Multiple and 

then enter At: 1.15.  Very relevant to the spacing before and after paragraphs is the 

option to Don’t add space between paragraphs of the same style. 

2. The second tab, Line and Page Breaks, also has nice features: 

a. Widow/Orphan control prevents a single line of a paragraph appearing on a 

single page.  Consequently, paragraphs that consist of up to three lines will 

appear on the next page if there is a page break, longer paragraphs where only 

one line appears at the bottom of a page will have that line moved to the next 

page with the balance of the paragraph, and if the last line appears on a new page, 

then at least a second line will also be moved to that new page, as well. 

b. Keep with next prevents a page break occurring between a paragraph with this 

style and whatever paragraph follows.  By selecting this option, it prevents titles 

from appearing at the bottom of a page (the title will be moved to the top of the 

next page), and it prevents page breaks between, for example, images and their 

caption, and tables and their captions. 

c. Page break before ensures that any paragraph with this style appears at the top 

of the next page.  This would be useful for a Heading 1 that designates, for 

example, a chapter. 

The styles we will modify include: 

1. Normal, 

2. No Spacing, and 

3. Heading 1 through Heading 9. 

3.4 Creating styles 

 

The first two style we will create is Itemized List and Source Code.  When creating a numbered 

or bulleted list in a document, the spacing is usually 1.15 spacing and the text is left aligned, 

while source code is usually shown with single spacing, left alignment, the Consolas typeface, 

and an offset (indented) from the surrounding text.  Consequently, while we could use the No 

Spacing style in both these cases, we would have to change the alignment, typeface and inter-

item spacing for each such instance within the report.  If lists and source code do not occur too 

often, this may be an acceptable solution; however, many engineering reports will contain at least 

itemized lists, and therefore it is useful to create an appropriate derived style for these two, as is 

shown in Figure 7. 
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Figure 7. The relationship of Itemized List and Source Code to No Spacing. 

  

Now, any change to the No Spacing style will automatically be inherited by both Itemized List 

and Source Code unless those have already explicitly overridden particular features.  Thus, 

1. changing the justification of No Spacing will have no effect on either descendent (both 

explicitly changed this to left alignment), 

2. changing the typeface of No Spacing will only affect the typeface of Itemized List 

(Source Code uses Consolas), and 

3. changing the color of No Spacing will affect both descendants. 

To create these, bring up the Styles dialog and having selected No Spacing on the list, create a 

New Style, as shown in Figure 8. 

  

Figure 8. Creating a new style. 
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This will bring up the Create New Style from Formatting dialog, as shown in Figure 9.  In each 

case, we give the style an appropriate name, and as soon as we have changed the name, we note 

that the Style for following paragraph: has been automatically updated to match the name.  

 

Figure 9.  The Create New Style from Formatting dialog. 

  

In both cases, we would select left alignment and Source Code would, additionally, be set to 

single spacing, a Consolas typeface and indented one to the right, all of which can be changed on 

this panel.   In addition, we would have to select Format→Paragraph… to bring up the 

Paragraph dialog, where we would select to [d]on’t add space between paragraphs of the 

same style. 
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3.5 Styles within this report 

Word allows the user to create styles, and the most significant benefit to styles is that a 

modification to a style is automatically applied to all text that is designated as being of that style.  

Thus, the most significant question one may ask when creating a style is:  might I want to change 

text in this context automatically and separately from other text?  Another feature of styles is that 

they can form hierarchies similar to the inheritance of classes in object-oriented languages.  

Consequently, properties held by a parent style are automatically adopted by all descendant 

styles.  With these two items in mind, we will discuss styles for 

1. the letter of submittal (and other formal letters) and the title page, 

2. the paragraph text in various components of the report, and 

3. section headings including those in the front and back matter, the body of the report and 

any appendices. 

We will start with the most straight-forward:  styles specific to the title page and the letter of 

submittal. 

3.5.1 Letter of submittal and title page styles 
The title page and the letter of submittal have numerous independent components, each of which 

may be change individually.  Consequently, these two pages have more styles than any other 

component of the report.  For example, in the letter of submittal, the author’s address appears at 

first, followed by the date and the recipient’s address.  One may initially ask:  why not just use 

single-line spacing and keep it simple?  While this is a valid point, and if you are only ever 

writing a single document, this may be appropriate; however, as an engineer, you will likely be 

authoring numerous such letters, so we will never-the-less demonstrate how and why styles 

should be used.  The author’s address is also known as the letterhead, and so while you may 

initially use a letterhead as simple as 

1600 Pennsylvania Avenue Northwest 

Washington, D.C. 

+1 202-456-1111 

at some point, you may wish the letterhead to be centered: 

1600 Pennsylvania Avenue Northwest 

Washington, D.C. 

+1 202-456-1111 

Thus, such a change can be made once in the style, as opposed to going to each such page and 

modifying the text by hand.  The components of a letter include: 
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1. Ltr Letterhead: the company or institution sending the letter, 

2. Ltr Letterhead Address: the address of said company, 

3. Ltr Date: the date of the letter, 

4. Ltr Recipient: the name and address of the recipient, 

5. Ltr Greeting: your initial salutation to the recipient (e.g., “Dear …,” or “To whom it 

may concern,”), 

6. Ltr Paragraph: the paragraphs of the letter, 

7. Ltr Closing: your final salutation to the recipient (e.g., “Sincerely,”), 

8. Ltr Signature: your name and uWaterloo student identification number over which your 

signature will appear, and 

9. Ltr Addenda: a list of enclosures and anyone copied on the letter. 

The first and last are not required for work-term reports—you are only required to include your 

address and your report does not contain any additional enclosures or require anyone to be copied 

on the report.  One desirable feature of styles is that as long as one uses soft returns (Shift-Enter) 

within a style, for all but the paragraph style, a hard return (Enter) will automatically transition to 

the next style, leaving the appropriate spacing in between.  For example, once the date is entered, 

as soon as the user presses Enter, the style will change to Ltr Recipient, and once that is finished 

(using Shift-Enter between lines), the next hard return will transition the style to Ltr Greeting.  It 

is only the Ltr Paragraph style that does not does not transition immediately to the next style, 

Ltr Closing; this must be done by manually selecting the Ltr Closing style from the styles listed 

in Home→Style grouping.  These components of the letter of submittal (and any formal letter, 

for that matter) are shown in Figure 10. 
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Figure 10.  The styles used in the letter of submittal. 

The components of the title page are less standard and in this case, they are very specific to the 

report being written.  The format of the title page will differ from program to program. 

1. TP Institution: University of Waterloo, 

2. TP Division:  your faculty and department or program (as specified), 

3. TP Title: the title of the report; 

4. TP Subtitle: a sub-title to the report (possibly blank); 

5. TP Employer: your co-op work-term employer (possibly blank); 

6. TP Employer Address: the address of your employer (possibly blank); 

7. TP Author, the author of the report; and 

8. TP Restrictions, additional information (possibly blank). 

These are shown in Figure 11.  As before, you should use soft returns (Shift-Enter) within a style 

(for example, if your title spans two lines and want to insert an appropriate line break or between 

the lines of your employer’s address).  In each case, a hard return (Enter) will move to the next 

style. 

For the purpose of this report, both the letterhead and the name address of the recipient.   
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Figure 11.  The styles used in the title page. 

When you consider whether or not it is worth specifying styles to such an extent, one must ask 

how much work is required to create the styles, and how many people will be using the styles in 

question.  In this case, with thousands of students writing work-term reports each term, it is likely 

worth the overhead.  In contrast, we will see that the number of styles used in the body of the 

report is less than either the title page or the letter of submittal.  Next we will discuss the front 

matter. 
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3.5.2 Contributions and summary 
The contributions and summary sections each require an unnumbered heading and an entry in the 

table of contents.  By default, any text designated Heading 1, Heading 2 or Heading 3 is placed 

in the table of contents, although later we will be restricting this to only the first two.  

Consequently, we will give each of the headings of these sections the style of Heading 1.  The 

body of the text within the contributions and summary sections should use Normal (Times New 

Roman, full justification and 1.5-line spacing) and No Spacing (also Times New Roman, full 

justification but with 1.15-line spacing) styles. 

3.5.3 Content listing 
Each engineering report requires a table of contents, a list of figures and a list of tables.  While 

the title of the latter two should appear in the table of contents, the entry “Table of Contents…” 

should not, and therefore the headings for the lists of figures and tables will both also be 

Heading 1. Later, we will see how to automatically create a table of contents, and Word will 

specify the style of the heading as TOC Heading, a heading style that does not appear in the 

table of contents.  If you investigate the TOC Heading style, you will note that it is derived from 

the Heading 1 style, and therefore any change to the Heading 1 style will be reflected in the 

TOC Heading style.  This inheritance is shown in Figure 12. 

 

Figure 12.  TOC Heading is derived from Heading 1. 

Each of the nine heading styles corresponds to a table of content style named TOC 1 through 

TOC 9, respectively.  These have been formatted appropriately for single listing.  When we 

automatically create our lists of figures and tables, the entries of those tables will be automatically 

given the style Table of Figures.  The styles of all of these have already been appropriately 

modified to be Times New Roman, left aligned with 1.15 spacing. 

3.5.4 The report body and multilevel lists 
We will discuss three components with respect to the formatting of the main body of a report, 

including  

1. the textual content, 

2. numbered section headings, and 
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3. figures and tables. 

Perhaps surprisingly, there will be only two new styles that we will introduce together with a 

class of derived styles from the nine default Word heading styles. 

The paragraph text within the body of a report should be Times New Roman with 1.5 line spacing 

and full justification, and therefore the Normal style will be most appropriate. For numbered or 

bulleted lists, such as appearing in the previous paragraph, should have the style Itemized List.  

If you were to include source code in your report (although you should seriously question the 

necessity of doing so), you would use the Source Code style.  The most significant issue, 

however, is the automatic numbering of your sections, a topic we will introduce next. 

As described in Section 3.1, an engineering report tends to have a reasonably common set of 

sections, and each of these sections must be numbered 1, 2, 3 and so on.  Similarly, different 

subsections should include an additional numbers, such as 3.1, 3.2, 3.3 and so on.  This sub-

subsection is the fourth such section within Section 3.5, and therefore has the section 

number 3.5.4.  To achieve this manually is frustrating at best, especially when one begins to deal 

with cross-references as we have in this paragraph (we will discuss this later).  In order to 

automatically associate such a numbering scheme with sections, it is necessary to create a new 

multilevel list, and we must link this multilevel list to a corresponding heading. 

Unfortunately, we have already used Heading 1 for section headings without number, and if we 

link this multilevel list to it, then will add numbers to the sections in the front matter: 

1. Contributions 

2. Summary 

3. Table of Contents 

4. List of figures 

5. List of tables 

Additionally, we will later want to similarly augment our appendices, so that we have 

Appendix A Heading of the appendix 

A.1 Section in an appendix 

A.1.1 Subsection of a section within an appendix 

It is not possible to link the same style to two or more multilevel lists, and therefore we must 

create derived styles from the default heading styles.  For now, we will create nine new styles, 

where Bdy n Heading is based on Heading n, as shown in Figure 13. 
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Figure 13.  The Bdy 1 – 9 Headings derived from the Heading 1 – 9 styles. 

At the start of the structural section forming the body, select 

Home→Paragraph→Multilevel List→Define New Multilevel List…. This will bring up the 

Define new Multilevel List dialog.  First, select More in the lower left corner.  We will first 

begin to get a numbering that is appropriate, as shown in Figure 14. 

 

Figure 14.  The Define new Multilevel list dialog after having selected More >>. 
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Achieving this is as easy as 1, 1.1, 1.1.1, by first selecting Set for All Levels…, which brings ups 

the Set for All Levels dialog.  Here, we will set: 

1. Bullet/Number position for first level:  0 cm, 

2. Text position for first level: 0 cm, and 

3. Additional indent for each level:  0cm, 

as shown in Figure 15. 

 

Figure 15.  Setting properties for all levels of headings. 

Next, you can change an individual heading’s appearance by selecting it under the Click level to 

modify: and changing, for example, the Number style for this level setting.  You will require 

numbers (1, 2, 3, …) for each level and you should set Follow number with: Space, as tabs tend 

to lead to inconsistent spaces between the number and the section heading description.  To 

include higher-level headings, you may select those from the Include level number from: drop-

down menu. 

Now, in the Define new Multilevel List dialog, select each of the nine levels and for the n
th
 level, 

select Link level to style: Bdy n Heading.  When we have completed this and selected OK, the 

derived styles will appear with the appropriate level of numbering, as shown in Figure 16. 

 

Figure 16.  The body heading styles based on the default heading styles. 

Each time you select any of the Bdy n Heading styles, it will automatically give that section the 

appropriate number.  If you delete such a heading, Word will automatically decrement, as 

appropriate, all subsequent section numbers to account for the removed heading; and if you add a 

new heading of such a style, Word will automatically increment, again as appropriate, all 

subsequent section numbers. 
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3.5.5 The report body and figures and tables 
The final two styles we will introduce here are for figures and tables.  The Figure style uses 

center alignment and the style of the following paragraph is set to Caption.  The Caption style 

also uses center alignment and the following style is set to Normal.  We will discuss how these 

can be used later. 

3.5.6 Appendices and multilevel lists 
Appendices, as sections within the main body, should also be numbered, although at the top level, 

it is usual to refer to Appendices A, B, C, etc.  Consequently, we must create a new set of 

headings for appendices, and we must associate a new Multilevel List with these new headings.  

As with Bdy 1 Heading, the top level heading is also based on Heading 1, and so on, as is shown 

in Figure 17. 

   

Figure 17 Styles for the heading of appendices. 

Consequently, as with section headings, the insertion of new appendices or sections or 

subsections within appendices, need not require the author to change the numbering. 

3.5.7 Summary of styles within this report 
The use of styles may assist in the regularization of standard documents such as formal letters, 

title pages, etc.; however, the vast majority of engineering reports are restricted to a small 

selection of styles usually involving the spacing of section headings, paragraphs, figures, and 

tables.  Section headings are were the features of Microsoft Word come in useful in maintaining 

the correct numbering and ordering of sections and subsections relative to each other.  By 

creating heading styles based on Heading 1 through Heading 9, it is possible to link these to 

multilevel lists, and therefore remove the need for the author to track the number of sections and 

appendices. 
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3.6 Tables of Contents 

The next step is to create a table of contents (TOC). Fortunately, if the document has been 

constructed with the appropriate Section 1, 2, and 3 styles for each section heading, the 

generation of a table of contents is automatic. Moving back to the second structural section (in the 

front matter), on a new page select References→Table of Contents→Table of Contents and 

select the second automatic table as shown in Figure . 

 

Figure 18. Inserting a table of contents. 

This will insert a table of contents; however, the specifications require that the title Table of 

Contents appears centred and therefore the default title may be erased and a new title using the 

style !TOC Section (a section not in the table of contents)  This style does not inherit from any 

Heading style and therefore will not appear in the table of contents (specifically, departmental 

guidelines state that the table of contents must not appear as an entry in the table of contents). By 

default, the table of contents shows any styles inheriting from Heading 1, 2, or 3; that is, 

including sub-subsections. To display only sections and sub-sections, it is necessary to edit the 

codes of the table directly. By pressing Alt-F9, the table is displayed as the text 

{TOC \h \z \u}. By changing this to {TOC \o "1-2" \h \z \u}, this restricts the table to 

showing only logical sections and subsections [4]. Departmental guidelines require that all 

sections be listed in the table of contents, but this may be distracting in larger reports. 

The table of contents must be updated by the author and therefore, the last operation that the 

author should perform is to select the table of contents (as well as other tables and lists) and in the 

top left corner, select Update table… and from the resulting dialog select Update entire table. 

To update all the fields (tables of contents, figures, etc.) in the document, press Ctrl-A to select 

everything and then press F9. 
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3.7 Cross-referencing Logical Sections 

At some point within a document, it will be necessary to explicitly refer to another section; for 

example, Section 6.2 will discuss cross-referencing figures. Consider manually typing in all such 

cross-references, and then realizing that what was Section 6 should now be moved to Section 4. 

The author would now be left with the daunting task of finding any references to Section 6, 

Section 6.N, Section 6.N.N, etc. and changing these all to refer to 4, 4.N, 4.N.N, etc. At the same 

time, previous cross-references to Section 4 would need to be updated to refer to Section 5, and 

cross-references to Section 5 would need to be updated to Section 6. Fortunately, Word has a 

mechanism which allows the author to refer directly to the specific number of a section. To refer 

to the number of a previous or future logical section, subsection, etc., without concern as to 

whether the number or title of that section will change if the section is moved or if new sections 

are added, one can use cross-references. Move the cursor to the location which should contain the 

desired cross-reference and select References→Captions→Cross-reference. This brings up the 

Cross-reference dialog shown in Figure . Set the Reference Type: to Heading to chose a top-

level section or set the reference type to Numbered Item to see all sections (though this also 

brings up all other lists within the document). Usually a reference is of the form “Section N”, and 

therefore one should type the word “Section ” and use Insert reference to: Heading number. In 

addition to a section number reference, one is also able to use Insert reference to: Page number 

in significantly larger reports to assist the reader in finding a section significantly removed from 

the reference itself. For example, in Section 8 starting on page 49 of this document will discuss 

how equations should be used in engineering reports. 
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Figure 19. The Cross-reference dialog set up for inserting a section number. 

3.8 Logical Sections and Paragraphs 

A new logical subdivision is never immediately introduced prior to a previous logical 

subdivision—each section must be introduced with at least one introductory paragraph that 

explains the purpose of the division and what will be covered any subsequent subdivisions. 

Where appropriate, the last subdivision of a logical section should summarize the section and 

introduce the next section to provide an appropriate transition. To demonstrate, one may argue 

that the topics in Section 4 are stated in the title, that is, “Page layout, reviews, and features to 

turn off”; however, even in this case, the author should give the reader the courtesy of a preamble, 

if nothing else, to introduce the material. The difference is shown in Figure  where the 

introductory paragraph is removed on the right-hand side. 
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Figure 20. A section both with and without introductory paragraphs. 

New sections, subsections, etc., should not start on a new page unless doing so would leave only 

a title and a line or two at the bottom of a page. 

3.9 Summary on Logical Sections 

This section has given an overview of using styles, numbered lists, and multilevel lists to partition 

the body of the report into sections, subsections, and sub-subsections. This automates the process 

of ensuring that the sections are correctly and sequentially numbered and allows the creation of a 

table of contents and cross-references, each of which will be updated. The numbering and 

referencing of figures, tables, and equations will be treated in a similar manner as described in 

Sections 6, 7, and 8; however, we will first continue with other features of Word. 

4 Page layout, reviews, and features to turn off 

This section will review some of the other tools necessary for preparing engineering reports:  

page layout, styles, and reviews.  In addition, other undesirable features are discussed together 

with a demonstration as to how to turn these features off.  This report does not cover all features 

of Word 2007; however, the ribbon interface makes it very easy for an author to browse the 

available capabilities and it is highly recommended that any serious author take the time to 

explore these features.  As a general rule (excepting equations), if a task seems unnecessarily 

tedious, there is probably an easier solution. 
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4.1 Page layout 

Two important features from the Page Layout tab are margins and the placing of watermarks.  

The Page Layout→Page Setup→Margins allows the user to set the margins and the 

requirement for work-term reports is that the top, right and bottom margins are each one inch and 

the left margin is one-and-a-half inches.  Consequently, it is necessary to select Custom 

Margins… and set the margins with 2.54 cm and 3.81 cm as appropriate.  The Page 

Layout→Page Background→Watermark feature allows the report to be marked as a draft until 

the report is completed.  This document has been marked as a draft to demonstrate this feature 

and to require a student who is modifying this document to explicitly turn this feature off.  

Turning this on immediately ensures that the author does not mistake a draft version when 

printing the final copy. 

4.2 Reviews 

A useful tracking feature of Word is the ability to make comments that are contained within the 

document but not printed with the final version.  By highlighting text and selecting 

Review→Comments→New Comment, the author, reviewer or editor can make a comment that 

can be referred to later without having to insert the text directly into the document.  This is used 

heavily in the front matter of this report to explain the purpose of the different aspects of those 

sections.  As the body will be significantly different for every report, comments are only included 

with the Conclusions and Recommendations sections.  Another related and powerful feature is the 

ability to track changes under Review→Tracking.  This allows the author, reviewer, or editor to 

make changes to the document and to also record what was changed.  These changes can then be 

reviewed and either accepted or rejected.  This is very useful when passing a report to an editor or 

reviewer and to see not only the changes he or she made but what was originally present and to 

accept or reject those changes.  

4.3 Features that should be turned off 

Word has many automatic correction and automatic formatting features which in some cases can 

be helpful, but in others can be exceptionally distracting.  For example, Word attempts to 

anticipate when the author is starting a numbered or bulleted list.  This should be turned off: open 

Word Options→Proofing→AutoCorrect options →AutoFormat and AutoFormat As You 

Type and deselect both automatic bullets and automatic numbering.  In addition, in the same 

dialog, it may be beneficial to turn off the automatic conversion of URLs to hyperlinks:  deselect 
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Internet and network paths with hyperlinks.  Turning these features off helps the author to 

better understand how the tool works rather than “Oh, if I do something like this, it will start a 

numbered list”.  This latter automatic approach essentially has the author learning—by 

observation and trial-and-error only—what the rules are for performing certain tasks. 

4.4 Summary of other Word features 

This section has given an overview of the page layout, styles, and reviews in Word.  In addition 

to these features, there are other automatic correction and formatting features that are better 

turned off.  Authors should also use the ribbon feature to explore other possible features that may 

be applicable.  This concludes the basic description of the use of Microsoft Word.  The following 

by four sections document the use of numbers, units, figures, tables, and equations within an 

engineering report. 

5 The display of numbers and units 

Every engineering report must contain some form of quantitative analysis and will therefore 

require the presentation of measurements, and while the purpose of an engineering report is to 

present recommendations for an engineering problem and to justify them, the mindless tabulation 

or presentation of numbers will not necessarily support this.  It is necessary, instead, to present 

those numbers that demonstrate the validity of the analysis or design in a manner that conveys the 

necessary information to the reader.  We will look at three aspects related to the presentation of 

numbers, including: 

1. the presentation of numbers and significant digits, 

2. the use of statistics, and 

3. the representation of units. 

The effective use of numbers, statistics and units will support the arguments of the author, while 

tabulated numbers and unclear units will obfuscate the analysis or design. 

5.1 Numbers and significant digits 

We will consider the display of significant digits within reports, appropriate means of tabulating 

numbers, asking whether the absolute magnitude is of highest priority, or the relative magnitudes, 

and issues with respect to formatting numbers. 
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The reporting of measurements should be restricted to the number of significant digits necessary 

to support the engineering analysis or design.  As an example, suppose two systems tested under 

five conditions, and their performance measurements are recorded as shown in Table 1. 

Table 1. The results of five tests. 

 1 2 3 4 5 

System A 73.93064 73.30655 73.59641 74.14493 73.41090 

System B 73.45006 73.15472 73.43668 73.02987 73.31573 

 

Unfortunately, by presenting all of the significant digits, it is difficult to quickly discern a pattern 

for the reader.  Instead, if we present only three digits, the reader can quickly discern the pattern 

the author is attempting to suggest, as is shown in Table 2. 

Table 2. The results of five tests. 

 1 2 3 4 5 

System A 73.9 73.3 73.6 74.1 73.4 

System B 73.5 73.2 73.4 73.0 73.3 

 

If the author believes the additional digits should, never-the-less, be presented, these could be 

listed in an appendix. 

When presenting numbers in a report, it is often useful to recognize that humans cannot seriously 

grasp the significance of either very large or very small numbers; after all, this is one of the main 

reasons for introducing a reasonable unit such as astronomical units (A.U.)—the distance from 

the Sun to the Earth—for discussing distances on the order of the Solar System, and barns—

approximately the area of a cross section of a uranium nucleus—for discussions related to the 

physics associated with particle scattering.  For example, comparing numbers such as 1590237 

and 890217 or 0.00001590237 and 0.00000890217 requires significantly more cognitive effort 

than comparing 1.59 and 0.89, and thus, while such numbers are mathematically correct, they do 

not help the author of an engineering report convey significance to the reader.  This is one of the 

reasons why the metric system introduced an ever increasing range of prefixes for different orders 

of magnitude; initially from milli to myria and today from yocto to yotta. 

When making a measurement with units involved, it is generally preferable to choose an 

appropriate unit to keep most numbers in the range from 0.1 to 99; it is easier for a reader to 

relate to 0.972 km as opposed to 972 m.  It is, however, important to keep the same units when 

comparing two or more values.  For example, Table 3 shows seven different representations of 

the same six numbers.  The reader is invited to quickly determine the order from largest to 

smallest. 
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Table 3 .  Seven repreesntations of the same data. 

Time Time 

(ms) 

Time 

(s) 

Time 

(s) 

Time 

(ms) 

Time 

(ms) 

Time 

(ms) 

  0.3594 s       359.4 0.3594       359400 359.4  3.594 × 10
2
 3.594 × 10

2
 

12.5 ms         12.5 0.0125         12500 12.5  1.25   × 10
1
 1.25 × 10

1
 

  0.1381 s       138.1 0.1381       138100 138.1  1.381 × 10
2
 1.381 × 10

2
 

  9.6 ms           9.6 0.0096           9600 9.6  9.6     × 10
0
 9.6 × 10

0
 

  0.0920 s         92.0 0.0920         92000 92.0  9.20   × 10
1
 9.20 × 10

1
 

  0.3 ms           0.3 0.0003             300 0.3  3.0     × 10
–1

 3.0 × 10
–1

 

 

Most readers will find the second and fourth columns the easiest to quickly determine the relative 

order.  This is because not only the values, but the shape of the numbers hints to their relative 

magnitudes.  While the third, fourth and fifth columns all present the same format (only with 

different units) the significance of the digits in the third column is lost with all the leading zeros, 

and the trailing zeros in the fifth column don’t carry any additional information—such use of ink 

that contains no data is referred to as chartjunk by Tufte, who we will meet again later.  Thus, an 

appropriate choice of units is also beneficial.  Even the pleasing alignment of the sixth column (as 

contrasted to the seventh column) does not help as the most significant number is also the 

smallest (the exponent).  While scientific notation is very useful [3], it must be noted that the 

reader can more quickly grasp the difference between 8.4 × 10
4
 and 12.0 × 10

4
 as compared to 

using pure scientific notation such as 8.4 × 10
4
 and 1.2 × 10

5
.  

Such a presentation, however, may not be beneficial if a trend is being presented, as in Table 4. 

Table 4. Six representations of exponentially growing data. 

Time Time (ms) Time (s) Time (s) 
Time 

(log10 s) 

Time 

(log10 ms) 

     0.4309 s       0.000 430 9               0.430 9 4.309 × 10
–1

 –6.366 –0.366 

30.85 s       0.030 85             30.85 3.085 × 10
1
 –4.511   1.489 

    1.610 ms       1.610        1 610. 1.610 × 10
3
 –2.793   3.207 

59.02 ms     59.02      59 020. 5.902 × 10
5
 –1.229   4.771 

 4.383 s 4383. 4 383 000. 4.383 × 10
6
   0.642   6.642 

 

Here, the second column shows the trend better than the first, but by choosing the units so as to 

anchor one end (in this case, the smallest), to within an order of magnitude of 1, the third column 

makes the trend clearer and allows the reader to more quickly grasp the relative difference in 

magnitude.  In the fourth column the continual increase in the exponents now becomes apparent 

to the reader, and is perhaps even clearer than the third column—the mantissa is ignored—but the 

steady increase of the logarithm of the values is much more easily apparent to the reader. 
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When comparing numbers with very different magnitudes, certainly comparing 1.2 m versus 

551 000 m may be better than 1.2 m versus 551 km or 0.551 Mm, but perhaps it may be simpler 

to state that the one distance is larger by a factor of 460 000; after all, in some cases, it may 

simply be clearer to show the relative difference between the numbers. 

Finally, it is appropriate to use Ctrl-Shift-Spacebar to prevent unexpected soft returns between the 

components of a number and to prevent full justification from stretching the number.  As an 

example of how soft returns can obfuscate numbers, compare the same number, 1.23456790123 × 

10
12

, 1.23456790123 × 10
12

 and 1.23456790123 × 10
12

 where—due to the use of full 

justification—only the second (using Ctrl-Shift-Spacebar both before and after the multiplication 

symbol) appears easily legible.  While this example was clearly constructed, it is never-the-less 

necessary to get into the habit of using Ctrl-Shift-Space, as subsequent changes to text before and 

after numbers may shift them from the middle of a line to either end. 

Thus, we have described how numbers should be displayed to an appropriate number of 

significant digits with additional precision relegated to an appendix, if necessary; who when a 

collection of numbers are meant to be compared, care should be taken when choosing the units 

and the appropriate SI multiplier; how relative magnitudes may be more appropriate in some 

cases;  and the appropriate use of Shift-Ctrl-Spacebar. 

5.2 Statistics 

There are two aspects of statistics that must be considered when attempting to clearly present 

quantitative data:  statistics is preferable to numbers were repeated samples may result in varying 

results, and linear regression is often the best technique for demonstrating the relastionship 

between independent and dependent variables.  

Statistics are an excellent way of summarizing and quantifying data; however, they can also be 

used to confuse, hide and mislead.  Consequently, the professional engineer must ensure that the 

statistics used are faithful representations of the data.  For example, if the distribution of marks in 

a class is normally distributed, it would be reasonable to state that the average is, say, 75 ± 15.  If, 

however, 43 students achieved grades from 90 to 100 and 49 students achieved grades from 50 to 

60 and the remaining 12 students received other grades, it would be misleading to say that the 

class average was 75 ± 20.  Please refer to Chapters 13 and 14 of Andrews et al. [3] and the 

classic text on the matter, Darrell Huff’s How to Lie with Statistics [5] for more information. 



 

32 

When presenting data that varies with respect to one or more independent variable (time, problem 

size, etc.), it is usually preferable, where possible, to use appropriate linear regression to find a 

best-fitting curve.  For xy-data (y depending on x) where local behavior is being described, an 

appropriate set of basis functions can be used (for example, 1, x and x
2
 if the behavior is 

quadratic); however, if asymptotic behavior (as the variables become very large or very small) is 

being described, 

1. if the growth is exponential, finding the best-fitting line of x versus ln(y), and 

2. if the growth is polynomial, finding the best-fitting line of ln(x) versus ln(y) 

will both produce straight lines; this is information that can easily be conveyed to the reader.  In 

either of these cases, a graph of the log plot and log-log plot, respectively, could be used to 

emphasize the relationship in question. 

Thus, where possible, statistics should be used, and when conveying the relationship between 

independent and dependent variables, linear regression in finding a best-fitting curve will often be 

the best means of conveying this information to the reader. 

5.3 Units 

Units provide a standard against which the properties of objects are measured.  Thus, 

measurements require a statement of the associated unit and this has been standardized by two 

means:  a standardization of the units through the International System (SI) of Units by the 

Bureau International des Poids et Mesures [6] and the consistent display of those units as 

documented in the National Institute of Standards and Technology  (NIST) Special Publication 

811 [7]  (see Appendix C) while Table 5 summarizes many of the best practices listed therein.  

Chapter 10 Measurement and Units from Andrews et al. [3] provides an excellent summary of the 

use of units.   
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Table 5. The best practices for writing units [7]. 

Best Practices Example Avoid 

Use SI units with correct capitalization 
m, g, m, kN, km, 

tonne, km/h, m/s 

ft, lb, um, KN, Km, 

ton, kph, kmph, mps 

Use correct symbols without plurals cm
3
, s, h, 3 cm, m 

cc, sec, hr, 3 cms, 

micron 

Avoid ppm, ppb, ppt, etc.
mg/kg, g/kg, ng/kg 

L/L, nL/L, pL/L 
ppm, ppb, ppt 

Leave a space or half space between the 

number and the unit (except for  °, '  and ") 

32.4 mL, 5 °C, 25 %, 

3° 4' 53" 

32.4mL, 5°C, 25% 

3 ° 4 ' 53 " 

Units are in roman font, variables are 

italicized 

3.2x m 

V = 3.2 V 

3.2x m 

V = 3.2 V 

Do not subscript units vmax = 5.325 V v = 5.325 Vmax 

% means 0.01 
The relative error is 0.2 %. 

(1  ± 0.2 %) 5.325 V 
5.325 V ± 0.2 % 

Do not label units The water flows at 3 mL/s. 3 mL(H2O)/s 

Use ‘to’ and not ‘–’for a  range 1 m to 7 m 1 m – 7 m 

Label all quantities with units 

1 MHz to 7 MHz 

(1 to 7) MHz 

17.4 MHz ± 3.2 MHz 

(17.4 ± 3.2) MHz 

1 to 7 MHz 

17.4 ± 3.2 MHz 

Do not mix unit names and unit symbols 
km/h 

kilometres per hour 

km/hour 

kilometers per h 

Use numbers and symbols or write 

everything out 
7 m or seven metres 7 metres or seven m 

An exception are adjectival units  
35 mm film 

35-millimetre film 

35-mm film 

35 millimetre film 

5.4 Summary of the display of numbers and units 

The display of digits should clarify and not obfuscate an engineering report.  Significant digits 

should be used where appropriate and statistics are very powerful tools to summarize data if used 

correctly.  Finally, units should be clearly marked in all cases as this provides the standard by 

which the measurement is made. 
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6 Figures 

A figure is a photograph or graphic meant to support the text of the report using a visual image.  

A figure is centred horizontally in the text and is immediately followed by a caption consisting of 

a label (e.g., Figure 6-1) and a brief description.  A figure must always be cross-referenced in the 

text by referring to the label.  The figure should appear either on the same page as the first cross-

reference or at the earliest convenient location following the first cross-reference.  As an example, 

Figure 21 shows a photograph of the Eyjafjalla glacier (Eyjafjallajökull) that covered a volcano 

which exploded in April of 2010 causing significant disruptions to European air traffic [8]. 

 

Figure 21. The Eyjafjallajökull which, until 2010, hid the Eyjafjalla volcano. 

The caption of the figure may be either a complete sentence or a title phrase, but, in either case, it 

is relatively shorter than the related discussion appearing in the surrounding text.  This section 

covers inserting and captioning figures, cross-referencing them, creating a list of figures, and 

considers other issues related to this topic. 

6.1 Inserting and captioning a figure 

To insert a figure on an empty line, select the style Figure which is automatically centred.  Next, 

paste an image into that position and resize it accordingly.  It is necessary to maintain the original 

aspect ratio of the image; otherwise, the image will appear distorted and will make the report 

appear as unprofessional as if there were a spelling or grammatical error.  To change the size, it is 

easiest to click on the image and move one of the handles in the corners—this will maintain the 

aspect ratio.  Do not attempt to resize the width and height separately.  Next, right click on the 

image and select Insert Caption… (or select References→Captions→Insert Caption).  Enter 

the appropriate information in the dialog making sure to add a period after the number.  Ensure 
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the Exclude label from caption check box is not checked; otherwise the label “Figure” will not 

appear before the number.  Figure 22 shows a screen shot of a caption being added to Figure 21.  

If text does not appear while typing the caption (Microsoft apparently does not expect centred 

captions), one can type a period, two spaces, a few words and select OK.  The caption will appear 

and at this point can be edited directly in the document. 

 

Figure 22.  Adding a caption to a figure. 

Some of the benefits of captions are that Word will not insert a page break between a figure and 

its caption (adding captions by entering text immediately below an image will result in the author 

having to check the entire document for page breaks between the figures and the captions); the 

numbering is easily updated if figures are added, removed from, or moved in the document; and a 

list of figures can be automatically constructed. 

6.2 Cross-referencing a figure 

Cross-referencing a figure elsewhere in a document without using the built-in tools has the 

potential for a word-processing nightmare:  Suppose the photographs of a dog and a lobster are 

inserted and, because they are the second and third image in Section 6, they is given the labels 

Figure 6-2 and Figure 6-3.  The author then dutifully cross-references the images by manually 

typing “Figure 6-2” and “Figure 6-3” in the text.  Suppose, however, at some point in the future, 

the author decides that it is necessary to include an image of boar immediately prior to the dog.  

Now, the boar would be given the label Figure 6-2,  the dog Figure 6-3, and the lobster Figure 6-

4.  All cross-references would have to be manually updated:  “Figure 6-2” would be changed to 

“Figure 6-3”, “Figure 6-3” would be changed to “Figure 6-4”, etc.  Fortunately, if a caption is 

added using the Insert Caption tool,  Word has a cross-referencing mechanism which allows the 

author to refer directly to specific figures and Word will track the labels.  At the location where a 
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cross-reference is to be added, select References→Captions→Cross-reference, in the dialog 

under the Reference Type select Figure and finally select the caption associated with the figure 

referred to.  The Insert Reference To drop-down box should be set to Only Label and Number.  

Figure 23 demonstrates how one can add a cross-reference to Figure 2. 

 

Figure 23.  The dialog box for a cross-reference to Figure 2. 

Word will highlight the entire cross-reference if the cursor is placed on any part of the reference. 

6.3 Lists of figures 

To create a list of figures, at the top of the page following the table of contents in the front matter, 

select References→Captions→Insert Table of Figures and in the dialog, choose Caption 

label: Figure and Include label and number.  This list must be updated before the report is 

printed and may either be done manually (by right clicking on the table and selecting Update 

Field) or globally by using Ctrl-A (select all) followed by pressing F9. 

6.4 Other issues with figures 

There are numerous other issues with figures that make them appear unprofessional:  a figure 

may be zoomed to the point that pixilation becomes apparent; the aspect ratio may not be 

maintained; and the author may not correctly use the appropriate image formats. 

6.4.1 Zooming small images 
First, never zoom a small image.  For example, Figure 24 and Figure 25 demonstrate how a 

105×70 image compares to a 784×599 image of the same University of Waterloo logo when 

scaled to the same size.  Illegible or blurry figures are unprofessional and not acceptable in any 

type of engineering report. 
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Figure 24.  A blow-up of a 105×70 image [9]. 

 

   

Figure 25.  A reduction of a 784×599 image [9]. 

6.4.2 Maintaining aspect ratios 
When an image is inserted into Word and the author clicks on it, handles appear at eight locations 

on the boundary.  If any of the corner handles is dragged, the image will change size but will 

maintain its aspect ratio.  If, however, one of the four intermediate handles is dragged, the image 

is stretched or shrunk in only that dimension.  For example, Figure 26 demonstrates what happens 

when Figure 25 is not shrunk correctly. 
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Figure 26.  A failure to maintain aspect ratio. 

6.4.3 Photographs and computer-generated graphics:  JPEG, PNG, and GIF 
Another property of images often overlooked by authors is the relationship between photographs 

and computer-generated graphics.  Photographs are digital approximations of natural images 

while computer-generated graphics are usually vector based and contain both greater contrasts 

and larger monochromatic regions than photographs.  The human eye averages details:  standing 

close to a brick wall allows the viewer to see the high-frequency detail of each brick but from 100 

m away the bricks will appear uniformly coloured and flat.  The JPEG (Joint Photographic 

Experts Group) image format is able to compress images by using this property and it removes 

the high-frequency details that the eye would naturally average anyway; the cost, however, is that 

the decoded JPEG image is similar to but not an exact copy of the original image.  Information is 

lost and therefore JPEG is a described as a lossy image format [10].  Unfortunately, lossy 

encoding is inappropriate for computer-generated graphics that often contain many abrupt 

transitions from one colour to another, which are high-frequency events.  Therefore, removing the 

highest frequencies will noticeably corrupt the graphic.  Figure 27 shows a zoom on Figure 25 

when the first is saved in the JPEG format. 
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Figure 27.  A zoom on Figure 25 saved as a JPEG. 

 

The speckling effect around any abrupt transition from one colour to another contrasting colour is 

easily noticed and appears unprofessional.  The PNG (Portable Network Graphic) image format 

stores an exact copy of the image and uses lossless compression [11] and, as a consequence, 

graphics are stored faithfully.  One issue is that PNG can use numerous algorithms for 

compressing large monochromic or similar regions but there is normally very little regularity that 

can be used for compressing photographs.  Consequently, a photograph stored as a PNG will be 

significantly larger than a JPEG and not noticeably different.  Figure 28 shows a photograph 

taken by the author stored as both a PNG and as a JPEG and it is much more difficult to detect the 

differences between the two formats as when compared to the differences between Figure 25 and 

Figure 27. 
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Figure 28.  The same image stored as a PNG (left) and as a JPG (right). 

Of course, there are differences, and if one zooms in on the images in Figure 28, as is 

demonstrated in Figure 29, the differences begin to become noticeable:  the JPEG algorithm 

partitions the image into 8×8 blocks and each block is compressed independently, which is 

relatively easy to detect; and, the colours in the JPEG image are not as rich as in the original PNG 

image.  Never-the-less, these differences are less apparent in photographs than they are in 

graphics. 

 

Figure 29.  A 500% zoom of the PNG (left) and JPEG (centre) images from Figure 28 

together with some of the more obvious blocking artifacts highlighted (right). 

Any images containing text or graphics superimposed over photographs must be stored with a 

lossless format.  Where possible, avoid using GIF format for images; this archaic format uses 8-

bit colour (for a maximum of 256 colours) and dithers to approximate different colours.  Figure 

30 shows the same image stored as a PNG which uses 24-bit colour, allowing 16 777 216 colours, 

and the same image using GIF. 
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Figure 30.  The same graphic stored as a PNG (left) and a GIF (right). 

The colours of the red and gold regions are each approximated by two differently coloured (or 

dithered) dots.  Once again, this is a known effect and is to be avoided. 

6.4.4 Summary of other issues with figures 
Figures should not be enlarged to the point that pixilation is apparent, aspect rations should be 

maintained (do not simply stretch or shrink vertically or horizontally alone), and be aware of the 

various file formats for storing images. 

6.5 Summary of figures 

The use of figures can be critical to conveying and summarizing information to the reader and 

standards have been developed for labeling, captioning, and referring to such images.  Word-

processing applications and typesetting systems will contain mechanisms for implementing these 

standards and users who learn these mechanisms will reduce the processing effort required to use 

figures.  In addition, authors must understand the two types of images, photographs and 

computer-generated graphics, and the two most common image formats, JPEG and PNG and use 

them appropriately.  JPEG and GIF formats must be used with care.  Closely related to figures are 

tables as discussed in the next section. 

7 Tables 

Tables are are used to present textual and numerical data.  In general, an array or list is a 

univariate (data depending on one variable or one dimensional) collection of information while a 

table is best used to present bivariate data (data depending on two variables or two dimensional).  

We will consider the appearance of tables, the presentation of data within tables, a discussion on 
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what should be presented in tables as compared to possibly more appropriate charts, and finally 

three- and four-dimensional tables. 

7.1 Creating and cross-referencing tables and adding lists of tables 

A table is created by placing the cursor on a new line, using Insert→Tables→Table to create the 

appropriately sized table, moving the mouse over the table and selecting the handle in the top left 

corner to select all cells, and changing the style to Table.  A caption is added to the table by right 

clicking on the top left handle and selecting Insert Caption….  Never use this handle to move a 

table—use cut-and-paste or  alignment (for example, centring the table).  Cross-references to 

tables are similar to cross-references to figures (see Section 6.2); simply choose the Reference 

type: Table.  A list of tables is generated using References→Captions→Insert Table of 

Figures and, in the appearing dialog, set Caption label: Table.  This list should be inserted after 

the list of figures in the front matter of the report. 

7.2 The appearance of tables 

The contents of any graph, chart, or table can be divided into ‘relevant data’ and ‘everything 

else’.  The higher the ratio of relevant data to other content, the more the reader will focus on the 

information and the less the reader will be distracted by what Tufte refers to as chartjunk [12], 

[13], [14], [15].  In today’s world brainwashed by lazy HTML-based tables, most people will start 

with monstrosities such as Table 6. 

Table 6.  An example table. 

 Column A Column B Column C Column D 

Row 1     

Row 2     

Row 3     

Row 4     

Row 5     

The reader will note that in such a table, the eye is attracted to the intersections of the lines.  

Unfortunately, Word makes the inclusion of additional chartjunk all too easy:  by selecting the 

Design tab from the ribbon, it is possible—as shown in Table 7—to maximize chartjunk with 

almost no effort.  The information will be negligible when compared to the layout. 
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Table 7.  The ultimate Word table without data. 

 Column A Column B Column C Column D Column E 

Row 1      

Row 2      

Row 3      

Row 4      

Row 5      

 

A table should minimize rather than mazimize the amount of chartjunk.  The next section will 

demonstrate how, by taking the table shown in Table 8, the data itself can be used to form the 

columns, thereby removing the need for the vertical lines.  

Table 8.  A table with a minimal amount of chartjunk. 

 Column A Column B Column C Column D Column E 

Row 1      

Row 2      

Row 3      

Row 4      

Row 5      

7.3 Presentation of data 

The step immediately following the creation of a table using Insert→Tables→Table is to select 

all entries in the table and change the style to Table. 

The next question is one of orientation:  in general, the independent variable should be listed in 

the first column while dependant variables should be listed across.  The reader is then able to 

view the data line-by-line where each line contains relevant information as a function of the entry 

in the left-most column.  This orientation also ensures that each column contains entries with the 

same units.  For example, Table 9 presents six elements and some of their properties.  The 

properties depend on the element and therefore the elements are listed vertically in the first 

column while the properties are listed across the table. 

Table 9.  The first six elements and some of their properties [16]. 

Element 
Atomic 

number 

Atomic mass 

(g/mol) 

State at 

STP 

Filling 

orbital 
Element category 

Hydrogen   1     1.00794(7) gas 1s
1
 nonmetal 

Helium   2     4.002602(2) gas 1s
2
 noble gases 

Lithium   3     6.941(2)  solid 2s
1
 alkali metal 

Beryllium   4     9.012182(3) solid 2s
2
 alkaline earth metal 

Boron   5   10.811(7) solid 1p
1
 metalloid 

Carbon   6   12.0107 solid 1p
2
 nonmetal 

Gold 79 196.966569(4) solid 6s
1 

metal 
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The alternative format would be to transpose the entries of Table 9 as is shown in Table 10.  

Table 10.  Transposing the entries of Table 9 [16]. 

Element  Hydrogen Helium Lithium Beryllium Boron Carbon Gold 

Atomic 

Number 
1 2 3 4 5 6 79 

Atomic 

Mass 

(g/mol) 

1.00794(7) 4.002602(2) 6.941(2)  9.012182(3) 10.811(7) 12.0107 196.966569(4) 

State at 

STP 
gas gas solid solid solid solid solid 

Filling 

Orbital 
1s

1 
1s

2 
2s

1 
2s

2 
1p

1 
1p

2 
6s

1 

Element 

Category 
Non-metal noble gas 

alkali 

metal 

alkaline 

earth metal 
metalloid nonmetal metal 

 

The font in the second table is necessarily smaller and it is no longer possible to easily detect 

patterns along the rows. 

The alignment of data within each cell depends on the type of data being presented.  Usually the 

first row provides a descriptive textual header for each column and should therefore be centred 

both vertically and horizontally.  If the values within the column are associated with a unit, the 

unit should appear below the header in parentheses.  The entries of the first column usually 

provide descriptive textual headings for each row and are usually left-aligned.  The alignment of 

the other columns depends on the entries:  

1. Significant amounts of text should be left-aligned; 

2. Shorter and repeated textual data should be centred; 

3. Integer data should be right-aligned; 

4. Numerical values which are the result of a measurements should be aligned with the 

decimal point—always remember that in any proportional font, two spaces usually 

equals one digit; and 

5. Equations should be aligned on the equal sign. 

However, all entries should, in general, be centrally aligned in the vertical direction.  All of these 

principles were demonstrated in Table 9.  To provide a comparison, Table 11 lacks the 

aforementioned techniques for displaying entries in a table. 
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Table 11.  A less pleasing version of Table 9 [16]. 

Element 
Atomic 

Number 
Atomic Mass 

State 

at STP 

Filling 

Orbital 
Element category 

Hydrogen 1 1.00794(7) g/mol gas 1s
1
 nonmetal 

Helium 2 4.002602(2) g/mol gas 1s
2
 noble gases 

Lithium 3 6.941(2) g/mol   solid 2s
1
 alkali metal 

Beryllium 4 9.012182(3) g/mol solid 2s
2
 alkaline earth metal 

Boron 5 10.811(7) g/mol solid 1p
1
 metalloid 

Carbon 6 12.0107 g/mol solid 1p
2
 nonmetal 

Gold 79 196.966569(4) g/mol solid 6s
1 

metal 

 

One feature in Table 9 is the vertical centring of all of the entries in the first row of the table.  The 

quickest way to achieve this effect is to select all entries, right click, select Cell Alignment, and 

choose both vertical and horizontal centering as shown in Figure 31.  After this step, it is possible 

to left or right-align the individual columns using the tools in Home→Paragraph. 

 

Figure 31.  Specifying centred alignment in both the vertical and horizontal. 

One of the more frustrating issues is listing numbers that should be aligned on the decimal point 

but where the width of the number is significantly less than the column title.  For example, 

consider three-digit numbers ranging from 0.100 to 99.9 which are required to appear in a table 

column with a title of “Relative Noise Comparison Ratio”.  In this case, it would be necessary to 

break the one column into three, merge the three cells containing the title, and place the numbers 

only in the central column.  The construction of such a column is demonstrated in Table 12 where 

the central column is left aligned and two spaces are used in place of each missing digit. 

Table 12.  Aligning and centring numbers. 

System 
Relative Noise 

Comparison Ratio 

Alpha      0.309  

Bravo      0.180  

Charlie      1.22  

Delta      1.96  
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Echo      7.46  

Foxtrot    31.6  

Golf    97.5  

 

The result without lines is shown in Table 13 and while its construction may be more tedious, the 

result is more pleasing and easier to maintain than any other type of alignment. 

Table 13.  Table 12 shown without lines. 

System 
Relative Noise 

Comparison Ratio 

Alpha      0.309  

Bravo      0.180  

Charlie      1.22  

Delta      1.96  

Echo      7.46  

Foxtrot    31.6  

Golf    97.5  

 

Without three columns, the table will appear as either as shown in Table 14. 

Table 14.  Table 12 shown with only one column. 

System 
Relative Noise 

Comparison Ratio 

Alpha     0.309 

Bravo     0.180 

Charlie     1.22 

Delta     1.96 

Echo     7.46 

Foxtrot   31.6 

Golf   97.5 

7.4 A table or a figure? 

A table should only be used when either exact values are necessary (e.g., numbers which are to be 

used or monetary values) when one of the columns cannot be ordered in a manner which is 

meaningful.  For example, the atomic number and the atomic mass in Table 9 may both be 

ordered and, ignoring gold, if the goal is to present the relationship between the two variables 

(and not their exact values), one could use a chart as is shown in Figure 32.  
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Figure 32.  The first six elements and their atomic masses. 

 

One issue with Figure 32 is that it occupies 120 cm
2
 or 20 % of this page, but it contains only 24 

data points (six actual points and six implied points for each of 2 1n  , 2n, and 2 1n  ); a data 

density of 0.2 items per square centimetre.  Higher data densities are both possible and desirable.  

The classical example of a chart with a high data density displaying many variables (in this case, 

army size and movement, specific locations, river crossings, battles, and temperature)  is Charles 

Joseph Minard’s chart showing Napoleon’s advance and retreat from Moscow in 1812-1813 [14]. 
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Figure 33.  Minard's advance and retreat of Napoleon from Moscow in 1812-1813 [14]. 

The other information in Table 9 (the state at STP, the filing orbital, and the category) can not be 

easily or more clearly presented using a graph and therefore a table is appropriate.  

7.5 Three- and four-dimensional tables 

The worst form of table is one that has only two columns or two rows—essentially a one-

dimensional array or list.  A standard bivariate table allows the possibility of the reader noticing 

correlations between the variables.  It is, however, possible to extend the number of variables to 

three or even four by further subdividing columns or rows.  For example, Table 15 shows specific 

values for the data points (1,C,x1), (1,C,x2), (2,C,x1), etc. with corresponding data points under 

column D. 

Table 15.  A three-dimensional table. 

Column A Column B 
Column C (units) Column D (units) 

x1 x2 x3 y1 y2 y3 

Row 1 T 0.532 0.537 0.541 0.823 0.398 –0.031 

Row 2 T 0.749 0.826 0.905 0.709 0.305 –0.102 

Row 3 F 1.302 1.421 1.538 0.543 0.201 –0.168 

 

While these techniques are seldom necessary, they can be very powerful when used properly.  

Even more interesting is the possibility of a four-dimensional table.  This involves the subdivision 

of both the columns and the rows.  Usually such a table will confuse the relationships rather than 

clearly present them; however, this author has seen this technique put to good use.  Table 16 
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demonstrates how values such as (1,x1,B,y1) may be displayed using such a table.  With this many 

entires, it may be necessary to include a few vertical lines to differentiate the columns. 

Table 16.  A four-dimensional table. 

Column A 
Column B 

y1 y2 y3 

Row 1 

x1 0.325 0.543 0.689 

x2 0.215 0.551 0.854 

x3 0.187 0.569 1.534 

 

To centre the table, click on the table and a handle (a box with arrows) will appear in the top-left 

corner.  Click on that to select the table and select Home→Paragraph→ centre.  In this 

example, when removing the grid lines, one may note that the correct lines are not the ones which 

are removed.  To correct this, there are tools available in the Design→Draw Borders group. 

7.6 Summary of tables 

Tables provide a useful means of listing quantitative data as opposed to the qualitative data 

presented by charts and graphs.  While it will be more difficult to recognize patterns, there are 

techniques to ensure that tables present information as clearly as possible.  There is always the 

question of whether quantitative numbers need be displayed in the body of the report or if it is 

more appropriate for the body to contain a qualitative but memorable and descriptive graph and to 

leave the quantitative data for an appendix.  Finally, it is possible, under special conditions to 

represent three- and even four-dimensional data using tables. 

8 Equations 

Both electrical and computer engineering are founded on the application of calculus and discrete 

mathematics which model the systems being developed.  The associated engineering analysis 

requires quantitative measurements and, consequently, almost all engineering reports will contain 

equations.  The art of digital typography of mathematical equations was greatly clarified by 

Donald Knuth when, after having written the first volume of his The Art of Computer 

Programming series, he took a sabbatical leave in 1978 to complete the TeX typesetting system 

[17].  His insights have become the de facto standard for displaying mathematical equations.  We 

will look at four aspects of equations in this section:  equations as parts of speech, the equation 

editor and MathType, references to equations, and writing equations. 
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8.1 Placing of equations 

An equation may either be placed in a sentence using the inline format as is shown by Guass’s 

law which states that 
0




  E  or, if the author wishes to draw attention to an equation, it may 

be placed centred on its own line in display format as is shown with Faraday’s law of induction, 

t


   



B
E

, 

which a student is expected to understand in ECE 375, Electromagnetic Fields and Waves.  If the 

author intends to cross-reference an equation elsewhere, in the report, the equation should be 

given a number.  For example, Ampère’s law states that 

 0 0
t

 
 

    
 

E
B J  (1)  

and this is another equation which is covered in ECE 375.  Having numbered this equation, it is 

now possible for the author to directly cross-reference Equation (1) directly elsewhere in the 

report, a process which is explained in Section 8.4. 

8.2 Equations as a parts of speech 

Unlike figures and tables, equations form a part of the text and their incorporation must therefore 

adhere to the grammatical structures of English.  For example, consider the sentence:  Whereas 

Newton’s laws of motion include his second law which states  
d

F m v
dt

 , Einstein’s general 

theory of relativity may be summarized by 

 
4

8 G
G g T

c
  


   . (2)  

In each case, if the equation is replaced by its English equivalent, the sentence continues to be 

grammatically correct:  “Whereas Newton’s laws of motion include his second law which states 

forces equals the time derivative of the product of mass and velocity, Einstein’s general theory of 

relativity may be summarized by the Einstein tensor plus the cosmological constant times the 

metric tensor equals eight times pi times the gravitational constant over the speed of light raised 

to the power four all multiplied by the stress-energy tensor.”  This clearly demonstrates the ability 

of equations to abbreviate and summarize complex phenomena.  An easier test for grammatical 

correctness, however, is to replace each equation with the phrase “the equation” or some other 
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appropriate phrase, for example, “the left equals the right”.  If, with such a substitution, the 

sentence continues to be grammatically correct, the structure and punctuation surrounding the 

equation are likely correct.  In the previous example, we have: “Whereas Newton’s laws of 

motion include his second law which states this equation, Einstein’s general theory of relativity 

may be summarized by this equation.”  The reader will note that the formula displayed by 

Equation (2) is followed by a period. 

8.3 The equation editor 

The default equation editor with Word 2007 is an in-house product of Microsoft.  In addition to 

having restrictions with respect to its functionality, it forces the author to use a new typeface 

named Cambria Math.  This new typeface is frustrating as its behaviour changes based on 

whether or not the font is used inside or outside an equation.  For example, an italicized “a” in a 

paragraph appears as “a” but in an equation it appears as “𝑎”.  Thus, all references to any 

variables which appear in an equation must themselves be equations—something which is neither 

necessary nor convenient.  For this and other reasons, it is necessary to install a better equation 

editor. 

The equation editor MathType from Design Science, Inc. is the professional version of Equation 

Editor 3.0—previously the default equation editor integrated into Word.  Equation Editor 3.0 is 

still present in Word for backward compatibility but it must now be accessed by using the 

Insert→Text→Object dialog.  With this inconvenience, it is better to download MathType 

directly from the Design Science web site (see Appendix C).  MathType costs approximately $59 

for an academic licence; however, it is possible to use this product for a free 30-day trial that 

allows the author access to the complete equation editor.  Once the thirty days pass, it is still 

possible to use the editor in Lite Mode where it continues to provide a plethora of 

options.   MathType in Lite Mode is functionally comparable to the older Equation Editor 3.0 but 

it adds a MathType tab to the ribbon and includes keyboard shortcuts that can be used to launch 

the Editor quickly and conveniently.  Lite Mode also has the advantage of sharing the same 

internal format as the full version of MathType, making collaboration with colleagues using 

MathType much easier and provides a smoother upgrade path for documents that may be edited 

with a full version of MathType in the future.  Once MathType is installed, it may be necessary to 

restart Word after which the MathType tab will appear on the ribbon. 
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To insert an equation inline as part of a paragraph, place the cursor at the point where the 

equation should be inserted and select MathType→Insert Equation→Inline which opens the 

dialog shown in Figure 34. 

 

Figure 34.  The MathType equation editor. 

The equation editor invites the author to begin typing an equation.  There are various buttons that 

allow different formats of expressions and the reader is invited to experiment with the tools 

available with a focus on the first two rows.  Four not-necessarily-intuitive characteristics should, 

however, be discussed:  First, because MathType formats the equations, by default, the space bar 

does not insert spaces; the equation editor will determine the spacing.  To force a space, it is 

necessary to choose the correct sized space under the  button, although this should be 

used sparingly and usually only when adding units.  Second, typing a parenthesis, bracket, or 

brace will yield a delimiter of 11-point size.  If, however, a delimited expression contains larger 

objects (e.g., fractions, powers, and matrices), it is desirable for the delimiters to be equal in 

height to the largest entry.  Use the  button to select the appropriate delimiting pair and 

the largest will be chose.  For example, compare 
0

sin

2

x
dx

x

  
 

 
  and 

0

sin
( )

2

x
dx

x



 .  

Third, choose compact integrals and sums where the limits appear to the right of the sign when 

creating an equation inline and chose the formal versions where the limits appear above and 

below the sign when creating a display equation.  For example, the previous inline integrals 

appears in display mode as 

0

sin

2

x
dx

x




 
 

 
 . 
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Finally, to change the font from italics to roman, select the Style menu and choose the appropriate 

entry.  For units, select the style text, e.g., the fox ran at 25 km/h .  The text style also allows the 

author to enter spaces normally. 

8.4 Placing and referencing equations 

Larger equations are usually displayed centred on a separate line.  If an equation is to be referred 

to elsewhere in the document, it is necessary to number the equation; however, because equations 

are part of the grammatical structure of the paragraphs, unlike figures and tables, it is not 

necessary to reference the equation before it appears.  The equation number appears to the right 

of the equation and, unfortunately, Word has no mechanism for doing this—all that Word allows 

are equation captions which appear either above or below the equation, neither of which is 

acceptable.  MathType has a mechanism for numbering equations, but this mechanism is only 

available with the full equation editor and not in Lite mode.  Therefore, it is necessary to use 

tables, numbered lists, and bookmarks to number equations.  First, on an empty line, change the 

style to Table and, using Insert→Tables, create a three-by-one table as is shown on the next line. 

   

Move the cursor into the table and a handle will appear in the top-left corner.  Right click on this 

handle and choose Table Properties… .  This brings up the Table Properties dialog and under 

the Column tab, use the Next Column button to change the preferred width of Columns 1 and 3 

to 10% and Colum 2 to 80%. 

   

The equation is centred in the middle cell and in the right cell, it is necessary to start a new 

numbered list using the format (1), (2), etc.  The list must be fully unindented using the tool in 

Home→Paragraph and then right justified in the same group. Finally, to reference the equation, 

it is necessary to bookmark the number.  Highlight the number and select 

Insert→Links→Bookmark.  Give the equation a name not using spaces.  Now that this is 

finished, select the entire table and under Design→Table Styles→Borders, select No Border.  

Next, to maintain the numbers, it is easiest to cut-and-paste this first equation to any other 

location which requires a numbered equation.  This automatically updates the equation numbers, 

but it is necessary to update all cross-references to the book marks using Ctrl-A (select all) and 

F9.  Cutting and pasting the table containing Equation (2) yields Laplace’s equation, i.e., 
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       
0

( )
st

f t f t F s e f t dt




   L . (3)  

To refer to such an equation, use the same Reference→Caption→Cross-reference tool as 

before but select the Reference type: bookmark and Insert reference to: Paragraph number.  

This will insert the number in parenthesis, for example, Laplace’s equation is shown in Equation 

(3), but unlike Figures, the word “Equation” must be explicitly typed.  It is necessary to search for 

dangling references and therefore it is a good idea to search for the text “Error!” before a report is 

printed.  Use Alt-F9 to view the codes which may make it easier to find dangling references. 

8.5 Typing an equation using text 

As a general rule, never type an equation directly into a paragraph.  Doing so will result in a 

number of formatting errors which will include not italicizing variables correctly (writing F = ma 

instead of F = ma), having a line break appear in an equation (G +  g = kT), not placing 

spaces around operators (as in y=ax+b instead of y = ax + b), using an x for multiplication (as in 

an m x n matrix instead of an m × n matrix), justification inappropriately stretching the equations 

(for example, F = ma 

instead of F = ma), using a hyphen in place of a minus sign (writing b
2
 - 4ab instead of 

b
2
 – 4ab), and word autocorrecting the equations (X

2
 + y

2
 = z

2
).  Almost all of these pitfalls can be 

easily avoided by using the equation editor.  The one exception to this rule is if there is a simple 

occurrence of a single symbol or variable, a function of one variable, or a number, all of these 

possibly with an operation which does not require a space (powers, absolute value, transpose, 

etc.); in these cases, it is more reasonable to type the expression as text.  For example, one may 

write that a matrix M is symmetric if it equals M
T
, or there are 2.54n centimetres in n inches.  

Small integers are usually written out in full as in “work-term reports are due seven days after the 

first day of classes.”  A summary of when italics or bold should be used for mathematical objects 

is given in Table 17. 
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Table 17.  Use of fonts in equations. 

Font Used For Examples 

Roman 
numerals, standard functions, units, 

descriptive text in subscripts 
3, 4, sin, cos, cm, eV, vmax 

Italicized symbols, variables, functions x, E, mp, G, f, y 

Bold matrices, vectors M, v, Mv = v 

 

The most useful short-cuts for creating mathematical objects are Ctrl-= to enter a subscript and 

Shift-Ctrl-= to enter a superscript.  If you wish to include a short equation such as n + 1, to avoid 

line wraps or stretching, use Shift-Ctrl-Spacebar instead of a simple space.  This way, you get 

n + 1 joined on the next line as a single unit instead of broken across the end of the line. 

8.6 Summary of equations 

Almost all mathematics or engineering text and reference books use similar if not identical 

formatting of equations.  The appropriate display of equations will make an engineering report 

appear to be professional while the abuse of equations will result in a document fo which the 

formatting will, in some cases,  distract from the content or even frustrate the reader.  We have 

now considered numbers, figures, tables, and equations.  We finish with three sections on the 

glossary, references and appendices. 

9 Building a glossary 

The glossary is used for defining both acronyms and technical terms.  The glossary follows the 

recommendations and comes before the references.  While it is possible to use the 

References→Table of Authorities tool to generate an appropriate glossary (though this is not 

using the tool for what it is intended and therefore certain corrections—i.e., hacks—must be 

made), it is easier to simply list the definitions alphabetically in the form demonstrated here: 

ECE:  Electrical and Computer Engineering. 

Um:  An interjection used by many students during their first technical presentation. 

Whatever:  A common colloquial term used by today’s youth to describe an indifferent attitude. 

WKRPT:  Work-term report—the abbreviation used in the University of Waterloo 

Undergraduate Calendar.  
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When a definition beyond the simple expansion of an acronym is given, the definition should be 

one or more complete sentences and not just phrases.  As the glossary is not part of the body of 

the report, any citations should appear as foot notes. 

10 Using references and citations 

A reference is a textbook, paper, or other external source which is used in the preparation of a 

report.   A list of all references is kept at the end of the body of the report following the 

recommendations and must follow the IEEE style guide [18].  Throughout the report, whenever 

information is used from one of the references, a citation to that reference should be added.  This 

section will discuss what to cite, how to install IEEE referencing format, and how to cite and 

build a bibliography. 

10.1 What to cite? 

All recorded knowledge is based on the prior work of others.  Any fact or idea that is not the 

work of the author must be cited with the exception of common knowledge or specialized 

knowledge that the report readers are known to possess.  A good definition of common 

knowledge is anything taught up to end of high school in any subject in general and anything 

taught in an undergraduate program for the subject area directly related to the object of the report.  

ECE students may assume that anything that they have learned up to the most recently cleared 

academic term of their program may be taken to be common knowledge.  Therefore, a discussion 

about basic semiconductors may not require a citation, but information about recent 

developments in device fabrication would require the author to cite a reference.  In addition, any 

technical information, figures, tables, diagrams, or any information taken from a manufacturer’s 

data sheets should all include a citation of the source document.  Submitting a report in which a 

source is not cited is considered to be plagiarism and is an example of academic misconduct 

under Policy 71 of the University of Waterloo [19]. 

10.2 IEEE referencing 

References are discussed under References→Citations & Bibliography; however, a quick 

inspection of the available Word styles quickly reveals that IEEE reference formatting is not 

available.  Fortunately, Yves Dhondt created an IEEE style which can be downloaded for free 

[20] (see Appendix C).  Download the IEEE – Reference Order style (IEEE_reference.XSL) and 

save it to the directory 
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C:\Program Files\Microsoft Office\Office1X\Bibliography\Style\ . 

If Word is open while the file is being saved, it will be necessary to restart Word before this style 

can be used.    Then, you can use References→Citations & Bibliography→Style:  IEEE 2006. 

10.3 Using citations and building a biblography 

A citation usually appears at the end of a contiguous string of sentences which takes information 

from a source and may be inserted by selecting References→Citations & Bibliography→Insert 

Citation.  This brings up a drop-down menu which contains all references that have already been 

added to the current document (from which one may be selected) and also allows the author to 

Add New Source… .  This second selection brings up the Create Source dialog shown in Figure 

35 and once the source is entered, the citation appears in square brackets. 

 

Figure 35.  The Create Source dialog. 

To create a list of references, create a page with the style F/B Section, the title References and 

use References→Citations & Bibliography→Bibliography→Insert Bibliography.  The 

bibliography must be updated before the report is printed.  A reference should only appear once 

in the list of references—do not have a separate reference for each citation of the same source—

and future citations of the same reference may be selected from the drop-down box under 

References→Citations & Bibliography→Insert Citation. 

10.4 Summary of using references and citations 

Citations are necessary to acknowledge that a source other than the author was used to obtain a 

fact, detail, or other form of information.  The act of using information from another source 

without a citation is plagiarism, which is academic and professional misconduct.  Fortunately, 
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Yves Dhondt created a style for IEEE referencing which allows the user to easily use the tools 

available in Word.  The author can build up his or her personal bibliography file so that the same 

references may be used for multiple reports.  

11 Adding report appendices 

The body of a report is meant to persuade and inform the reader about the engineering analysis 

and judgment that went into the conclusions and recommendations of the report.  Raw data does 

not convey significant information; however, the analysis thereof results in the conclusions and 

recommendations of the report; therefore, the data should be present.  The most appropriate place 

for such data is in an appendix in the back matter.  This way, the reader is not overloaded with 

unnecessary information but still has the opportunity to refer to the data.  Appendices may also 

contain source code provided that it is relevant to the report.  They must be cross-referenced in 

the body of the report and should appear in the same order in which they are mentioned (similar 

to citations and references).  Appendices use footnotes for citations as, in some cases, an 

appendix may be detached from the report body yet should remain a self-contained document.  
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12 Conclusions 

From the analysis in the report body, it was concluded that there are many tools available in 

Microsoft Word to assist the user in preparing work-term reports that satisfy the work-term report 

guidelines.  In almost every case, the assistance requires perhaps a few seconds to implement; 

however, once the report is close to completion, the installed tool makes it easy to modify the 

body of the report and still maintain consistent references and numbering.  The table of contents, 

list of figures, and list of tables may be prepared automatically.  Sections, subsections, and sub-

subsections, captions for both figures and tables, and equations can be numbered automatically 

and cross-referenced without concern if the item is to be moved within the document.  Citations 

and references can be generated automatically with the appropriate add-on to follow the required 

guidelines.  Without using these tools, a student will, near the end of the report, spend more 

energy in maintaining the appearance and consistency of the report and consequently will ignore 

more critical components such as flow, clarity, consistency, spelling, and grammar. 
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13  Recommendations 

Based on the analysis and conclusions in this report, it is recommended that each student who 

intends to work in a Microsoft-dominated environment should learn to use the tools available for 

Microsoft Word in addition to reading and following the work-term report guidelines.  These 

tools apply structural and logical divisions of sections, subsections, etc., of the document and 

other features of Word; the proper use of numbers, units, figures, tables, and equations; and the 

glossary, references, and appendices.  The awareness and use of the cross-referencing tool is 

essential to ensuring that all internal references remain consistent and up-to-date.   
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Glossary 

chartjunk:  A term coined by Tufte
1
 describing any component of a graph or chart which is not 

necessary to to convey the information therein. 

GIF:  Graphics Interchange Format—an archaic image format inappropriate for any form of 

graphics. 

JPEG:  Joint Photographic Experts Group—a lossy image format for photographs named after 

the group  

logical section:  The division of the body of the report into sections comprised of related 

paragraphs discussing ideas related to the same topic. 

lossless image format:  An image format which produces an exact copy of the original image 

when decoded. 

lossy image format:  An image format which will, in general, produce a similar but not exact 

copy of the original image when decoded. 

NIST:  National Institute of Standards and Technology—a non-regulatory American federal 

agency advancing measurement science, standards, and technology.
2 

PNG:  Portable Network Graphic—a lossless image format appropriate for graphics 

structural section:  The division of a Word document into separate sections, each of which may 

be given a separate format including header and footer 

SI:  International system of units (the metric system) 

TOC:  Table of Contents. 

WKRPT:  Work-term report.  

WYSIWYG:  What you see is what you get—in this case, the appearance of the printed 

document is identical to what is seen on the screen. 

  

                                                   

 

 

1
 E.R. Tufte, The Visual Display of Quantitative Information, 2nd ed. Cheshire: Graphics Press, 2001. 

2
 Public Affairs (2010, April) NIST General Information. [Online].  http://www.nist.gov/ 
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Appendix A Word 2010 checklist 

Before submitting an engineering report in Word, it is advised that the author take the following 

steps: 

1. Under Review→Tracking, set the display to Final.  This will hide the comments when 

the document is printed. 

2. Select View→Zoom→One Page and page down through the entire report ensuring that 

there are no inappropriate page breaks.  This includes a section heading at the bottom of a 

page or only one or two lines of a paragraph at the bottom or top of a page.  At the same 

time, scan for spelling and grammatical errors. 

3. Select the entire contents by using Ctrl-A and pressing F9.  This will update all fields. 

4. Search (Home→Editing→Find) for the six characters “Error!”.  This is part of the 

warning message “Error! Reference source not found.” printed when a cross-reference 

is not found.  To remove such dangling cross-references, it is sometimes more convenient 

if the codes are revealed through Alt-F9.   

5. Look through the table of contents and the list of figures and tables.  All citations (e.g., 

[1], [2], etc.) should be removed and longer captions may be shortened.  These tables 

may be modified; however, if the tables and lists are updated once again, any citations 

will reappear. 

6. Go to the bibliography, make any necessary changes, and remove all hyperlinks by right 

clicking on the hyperlink and selecting Remove Hyperlink. 

7. In all structural sections which contain watermarks, 

Page Layout→Page Background→Watermark→Remove Watermark. 

8. Finally, scan through the document again. 
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Appendix B Styles used in this report 

Many styles have been prepared for this work-term report document.  They are saved with this 

document, but they can also be downloaded at WKRPT.dotx.  The properties and descriptions are 

listed in Table 18.  . 

Table 18.  Styles used in this document. 

Style Spacing Alignment 
Paragraph 

Spacing 
Comments 

Normal 1.5 Full 1 
Used in the body of the report as well 

as the contributions and summary 

No Spacing 1.5 Full 1 
Used for the letter of submittal and 

back matter (including appendices) 

Itemized List 1.0 Left 1 For bulleted or numbered lists of items 

Figure 1.5 Centered 1 For images. 

Table 1.0 Left 1 For the content of tables. 

Caption 1.0 Centred 1 For the caption of a figure 

Source Code 1.5 Left 1 
For source code, in the Consolas 

typeface 

Bdy 1 – 9 

Heading 
1 Left 1 

Headings in the body of the report:  1, 

1.1, 1.1.1, 1.1.1.1, … 

Heading 1 – 

9 
1 Left 1 

Headings for the front and back matter 

(but not the table of contents and 

appendices) 

App 1 – 9 

Heading 
1 Left 1 Headings for the appendices 

TOC 

Heading 
1 Left 1 Heading for the Table of Contents 

TOC 1 – 9  1.15 Left 1 
Entries of headings in the Table of 

Contents 

 

The title page includes the styles: 

TP Institute 

TP Division 

 

TP Title 

TP Subtitle 

 

TP Employer 

TP Employer Address 

 

TP Address 

TP Restriction. 
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The letter of submittal includes the styles: 

Ltr Letterhead 

Ltr Letterhead Address 

 

Ltr Date 

 

Ltr Recipient 

 

Ltr Greeting, 

 

Ltr Paragraph 

 

Ltr Closing 

 

Ltr Signature 

Ltr Addenda 
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Appendix C Necessary downloads and installations 

1. Download A. Thomson and B.N. Taylor’s Guide for the Use of the International System of 

Units (SI)
3
 at 

http://physics.nist.gov/cuu/pdf/sp811.pdf 

2. Download the IEEE - Reference Order XSL file from 

 http://bibword.codeplex.com/releases/view/19764 

and copy the file to 

C:\Program Files\Microsoft Office\Office12\Bibliography\Style\ 

or 

C:\Program Files (x86)\Microsoft Office\Office12\Bibliography\Style\ 

3. Download and install the MathType equation editor from design science at 

http://www.dessci.com/en/products/mathtype/ 

 

                                                   

 

 

3
 A. Thompson and B.N. Taylor, "Guide for the Use of the International System of Units (SI)," NIST, 

Special Publication 811, 2008. 
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